Monday, 18 December, 2000

Problems with Windows 2000 SMTP Service

Maybe I'm just getting too old for this stuff.  With Windows 2000 on my machine now, I figured I could start the SMTP service so that my applications that need to send mail could use it rather than the SMTP service on my Linux box.  Not that I have anything against the service on the Linux box—it works fine—but that box is pretty volatile because I'm forever mucking with it.  Plus, the apps that need the SMTP service are running on my Win2K box so it just seems easier to have the service running there too.  That way I know that it'll be running when my apps need it.

Now I had no trouble setting up the SMTP service on my Win2K box at work, and I'm running the same version here.  But I can't get the darned thing to send mail.  My app can connect to the service, and the service accepts the mail.  But then it just drops it into the queue.  Strange.  I'm beginning to think that the Microsoft SMTP service wants my computer  to be connected to an honest-to-Pete domain before it'll try to send mail.  Egads.

Until I figure that one out, I have the SMTP service on my Win2K box using the Linux box as a "smart host."  Basically, all mail requests that go to the Win2K SMTP service get sent immediately to the Linux SMTP service.  There's still some good here.  Previously, if the Linux box wasn't running, my application would report an error (SMTP service unavailable) and the mail would never be sent.  Now, the mail is delivered to the Win2K box, and forwarded when the Linux box is next available.

I think I'd be happiest, though, if I could get the equivalent of the Linux sendmail program running on my Win2K box.  Guess I'll have to go searching for that one.